Get in touch
Back
Downtime

Screened services unavailable

Started 28 Dec at 11:20pm GMT+8, resolved 28 Dec at 11:54pm GMT+8.

Screened
Resolved

The issue has been resolved. From 11:12pm to 11:54pm GMT+8, Screened services were unavailable to all users. Full access was restored by 11:54pm GMT+8.

The root cause was traced to a misconfiguration during one of our nightly updates. After identifying the issue, we rolled back the change, restoring service immediately.

In the coming weeks, we will significantly refactor our delivery systems with added safeguards to prevent this class of outage from happening again:
- Implementing additional pre-deployment tests to catch configuration errors before they go live.
- Enhancing real-time monitoring to detect and alert on failures as they happen.

We know that downtime impacts your business, and outages like this are unacceptable. While we fell short this time, we’re committed to learning, improving, and ensuring a more reliable experience moving forward.

Thank you for your patience and trust in Screened.

Posted 28 Dec at 11:54pm GMT+8.
Created

We are currently experiencing an outage for Screened services. We are currently investigating and working to restore functionality as soon as possible.

Posted 28 Dec at 11:20pm GMT+8.