Get in touch
Back
Resolved

Partial outage of some screening services

Started 20 Jan at 02:00pm GMT+8, resolved 20 Jan at 04:58pm GMT+8.

Screened
Resolved

The issue has been resolved. From 2pm to 4:58pm GMT+8, some Screened services experienced partial downtime. Full access was restored by 4:58pm GMT+8.

The root cause was traced to a third-party service disruption. After identifying the issue, we deployed a fix, restoring service.

In the coming weeks, we will be expanding failover coverage to reduce the impact of similar disruptions.

We know that downtime impacts your business, and outages like this are unacceptable. While we fell short this time, we're committed to learning, improving, and ensuring a more reliable experience moving forward.

Thank you for your patience and trust in Screened.

Posted 20 Jan at 04:58pm GMT+8.
Created

We are currently investigating issues reported with Screened services and are working to restore functionality as soon as possible. We will provide another update in 4 hours or as soon as more information becomes available.

Posted 20 Jan at 02:00pm GMT+8.